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2.5D SOLIDS TUTORIALS

About the Tutorials
This chapter contains step by step instructions for creatingmodels for a variety of parts. Themodels
in this chapter will bemachined in theMachining Exercises so be sure to save them for later use.
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#1: 2.5D CAP

1. Create a new part named Cap.vncwith
themmdimensions shown.

2. Open the Solid Modeling
palette.

3. Open the Create Solid palette.

4. Open the Cuboid dialog.

5. Enter the data in the Cuboid dialog as
shown and Click the Do it button (or
press Ctrl+.).

Pressing the Stock Dim. button will enter most of the data so that only the Max Z field needs to be
changed.

6. From theGeometry Creation palette , select Shape then rectangle and create
the rectangle as shown. Change view to isometric (Ctrl+I).
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7. Double-click the cube to place it in the Body Bag.

8. Switch to the home view (Ctrl+H).

9. Create the circle shown.

10. Select the circle and choose Plug-Ins > Geoedit
Split. Enter 4 for the number of sections then Click

(or press Ctrl+.).
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11. ChooseModify > Transform > 2D Rotate, enter the values
shown. Double-click the circle to select all of it, then Click the
Do it button.

12. Close the Rotate dialog. Click away from the part to deselect and

from the Create Solid palette open the loft dialog.

13. Ctrl+click the sync points as shown below.

Method 1 - Shape Sequence Method 2 - Shape to Shape

Select each point in sequence and in the direction of the loft, from the circle to the
square, Click Do it.

Alignment points are used to determine how the shapeswill be aligned and blended. Alignment
pointsmust be selected in the right order. Alignment points can be selected in two ways,
selecting alignment points from shape to shape or select a single shapes alignment points, in
order, followed by the next shape in the same order.
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14. Click the cube then Ctrl+click the loft shape. (Make sure Face selection is deselected
to select entire body).

15. Subtract the loft from cube.

16. Create a Rectanglewith the Fillet Radius shown.

17. Click New CS from the CS list.

18. Create CS2 and label it XZ plane.

19. Open the CS palette.

20. Click the XZ button.
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21. Switch to the home view (Ctrl+H).

22. Create the profile geometry in the XZ plane.

23. Switch to XY plane.

24. Switch to the isometric view (Ctrl+I) and Double-click the cube base to place it in the Body
Bag.

25. Select the profile and open the Sweep Solid dialog.

26. Place the Base Curve pointer on the
rectangle with fillets and Click the Do it
button (or press Ctrl+.).
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27. Open the Rectangle dialog and enter the
following dimensions.

28. Select the square and create the extrusion
shown.

29. Subtract the tapered extrusion from sweep.

30. Switch to the XZ plane.

31. Create the points shown below.

32. Create the 40mmarc terminated
between the two points as shown.
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33. Select the arc and Revolve the arc with the following
information.

34. ChooseModify >Transform> Translate and enter the following
values.

35. Select the revolve and Click the Do it button.

36. Subtract revolve from sweep.

Note that the sweep is now two disjunct shapes but onemulti-lump body.

37. Select the sweep and Separate it.

38. Add the swept shapes to the
modified cube.

39. Save the part file.
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#2: BUILDING A SPHERICAL ELLIPSE

The Challenge
You need to create a concave elliptical where the lowest point is in the center.

The Problem

The print specifies values for one quadrant of
the 3D shape; this is how wemight normally go
about building the part, one quadrant at a time.
We build the first quadrant and then create a
Coons Patch between the geometry. We then
duplicate andmirror the Coons Patch sheet
over the X and Y center lines and stitch the
sheets together. This result looks like the
finished shape wewant.

However, there is a problemwith thismodel
that cannot be clearly seen until the part is
machined. If you turn on “Show Edges”, you
can see the intersecting lines running through
themodel. These intersecting lines run parallel
to the X and Y axes at the centerline. When the
part ismachined, these lineswill show up as if
they have beenmagnified. Themodel, not the
machining, is the cause of the problem.

Is this problem unique to GibbsCAM?No, this is the result of poor modeling techniques and will be
reproduced in any other CAD or CAD/CAM system unless a better set of modeling techniques is
used. GibbsCAM ismachining themodel exactly as it was built.

The Solution
To create a single continuous 3D flowing shape wewill create a “3 Point Arc” on the XZ CS,
another “3 Point Arc” on the YZ CS and then Sweep a sheet over these two arcs. Create a 3 Axis
Vertical Mill part, X:–40/+40, Y:–30/+30, Z:–20/0mm. Follow the steps below:

Step #1

1. Create an XZ plane.

2. Create points at X–35, D0, Z0 then at X0, D0, Z–8 and lastly X+35, D0, Z0.
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3. Select the points we just created.

4. Create a “3 Point Circle” (the circle will have a radius of 80.563mm).

5. Terminate the circle with the points at X–35 and X+35.

Step #2

1. Create a YZ plane.

2. Create points at Y–25, Z0, X0 then Y0, Z–8, X0 and Y25, Z0, X0.

3. Select the points we just created.

4. Create a “3 Point Circle” (circle will have a radius of 43.063mm).

5. Terminate the circle with the points at Y+25 and Y-25.

Step #3

1. Switch to the XY plane.

2. Open the Surface Modeling palette.

3. Open the Sweep Sheet dialog.

4. Set the sweep options as shown.
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5. Place the base curve pointer on the curve
shown and double-click the other curve
as the drive curve.

6. Click the Do It button to create the sheet.

7. Create a cube based on the workspace stock dimensions.

8. Slice the cube with the swept sheet function.

Now you have a continuous shape which does not have quadrant intersections. Turn on Edge
Selection and you will only see the edges of the spherical ellipse at the top surface of the body.
There are no edges in themiddle of the spherical ellipse like we saw with the quadrant building
technique. Youmaymachine as desired (the sample part uses a lace cut) and you will not see
any lines in this area as you did before.

9. Save the file.
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REPLACE HISTORY
In this tutorial we are going tomodify amodel to create a pocket. Wewill machine the pocket with
saved processes. After wemachine the part we will import a new body that represents a
redesigned pocket. Using Replace, we will recreate themodel and redo themachining.

Part Creation
1. Open part file Swap Example.vnc.

This part file has 2 bodies — Block and Pocket. Pocket is currently not visible as it is in the Body
Bag.

Block Pocket

Saved Processes

The first thing wewill do ismake the saved processes available for use.

1. Open the Sample Parts\Solids\Required\SolidSurfacer\Swap & Replace folder and copy the Swap
Processes folder toMyDocuments.

Placing the saved processes here will make it easy to find themwhenwe need them.
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1. Right-click a Process tile and from the
menu choose Load Process List, then Set
Folder.

This will now be the default location that
processes can be loaded.

2. Navigate to theMyDocuments/
Swap Process directory and click
Select Folder.

Placing the saved processes here will make it easy to find themwhenwe need them.

Unstitching and Subtracting “Pocket”

Opposite isometric
view (Ctrl+Alt+I)

We are going to unstitch the body named Pocket to close
off the shape, thereby creating a core. The interior
topology is not important; it is the exterior shape wewill
be subtracting from the Block.

1. Turn on face selection and Right-click the bottom flat face of the pocket body.

2. Choose the Select> Select Faces Above option.

All faces inside the pocket except the flats on top of the bosses should be selected.
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3. Select the two flat tops of the bosses, as shown
above.

4. Click the Unstitch button.

This results in two solids.

5. Select and Delete the smaller of the two resulting solids.

We do not need the core that was created, but we need the filled pocket body.

6. Subtract the filled pocket from the Block.
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Machining the Part
Loading Processes.

1. Right-click the Process list and select
Load Process List. This time themenu
will display files in the folder we set.

2. Choose 1) Rough Pocket.prc. There will be a slight delay as the Tool and Process that comprise
this pocketing process are loaded.

3. Select the faces in the pocket the samewaywe selected the faces for the unstitch. Create the
toolpath.

4. Deselect the Operation tile and Clear the process tile.

5. From the Processesmenu select Load and choose 2) Finish Pocket.prc and create the toolpath.

6. Render the operation.

7. Deselect the operations and place themodel in the Body Bag.

Modifying the Part
Importing the Changed Pocket

Weare now going to import amodel that is a different pocket shape.Wewill use the Replace
function to insert it where the filled Pocket bodywas used.

1. File> Import the file Large Cover.x_t from the Swap & Replace folder.
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Replacing the Model History

1. Aswith the smaller pocket shape, Right-click the bottom face and choose Select> Select
Faces Above and then select the tops of the two bosses.

2. Unstitch the solid to fill it and Delete the smaller solid.

3. Double-click the graphic to extract the smaller filled pocket
from the History of the Block.

4. Select the filled Large Cover solid then the smaller filled pocket. Click the Replace
button.

You will not see any changes but youmay be wondering whywe had to unstitch the larger
pocket. Shouldn’t we be able to just extract the original smaller body and replace that? The
answer is, in this case, no. Themodeler is not able tomatch up the faces of the two bodies. If we
were using a function that was not face-dependent (translate, booleans, and so forth) we could
just select the two original bodies and perform a swap or replace.

5. Right-click the Blockmodel and choose

Rebuild.

Redoing the Operations

Now wewill update the operations based on the new model.
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1. Select Edit > Redo All Ops and render
the part.

2. Save the file; it is complete.
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MACHINING SOLIDS

About these Tutorials
The part models for all of the following exerciseswere created in theModeling Exercises chapter of
thismanual. If you have not gone through those exercises and created the solid models for these
parts, you should do that now.We assume you are familiar with the interface and the principles
presented in theMill and Advanced CSModules. If you are unfamiliar with that information please
read through thosemanuals before attempting the following tutorials.

All parts in these exercises are assumed to bemade of cast aluminum alloys. The feeds and speeds
are all defaults, based on the CutDATA™ values. The exercises do not provide a step for setting the
material but if you have CutDATA, please set the part material when you open the part file. If you do
not have CutDATA simply use the default material — stainless steel. The feeds and speedsmay be
set by clicking on the calculation buttons.

Pockets and Contours
In this exercise, we will use a pocketing process to rough the part. The part will be finished using
Contour operations on the whole body and selected faces.

Part Setup

1. Open the 2.5D Solids part Cap.vnccreated in
modeling exercises. Set the Global Settings in the
Machining Preferences tab of the DCD as shown.

2. Ensure that the part has a Clearance value of 15mm.

3. Create the following tool list.

# Type Total Length Diameter Bottom
Radius # Flutes Flute Length Material

1 FaceMill 50mm 50mm 0mm 5 11.5mm HSS

2 Rough
EM 92mm 16mm 0mm 3 32mm TiN Coated

3 Finish EM 66mm 10mm 2mm 3 16mm TiN Coated
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Machining the Part

#1, Face Milling

First we will FaceMill the part.

1. Create this roughing
processwith tool #1.

This will clear off the top of the part. FaceMilling is not dependent on having a solid to machine.
Facemillingmachines either selected geometry or the workspace stock.

2. Create the toolpath.
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#2-3, Pocketing

1. Create this Roughing
processwith tool #2.
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When all of the options are set, create the operation.

The Use Stock option will trim the toolpath to the stock condition. Since this is an open pocket we
can get some drastically different results. If you wish to see the difference, try re-doing the
operation with Use Stock off.

The Rough tolerance setting allows us to generate toolpath faster with looser tolerances. This
will be fine since we are going to finish the surface in the next group of operations.

2. Create the toolpath and render.

This process creates two operations.
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#4-5, Contouring

Wewill now do the first of two sets of contour operations to finish the profile.

1. Create this Contour processwith tool
#3.

The Desired Z Step determines how
smooth the wall will be. Alternatively,
the Ridge Height option can be used to
specify the part’s smoothness. Often
the rendered part is far more accurate
in showing any scallops that are on the
part than our eyes can discern.

2. Create the toolpath and render.

This operation produces smooth toolpath that wraps around the walls of the part. When
rendered your part will look similar to the image to the right. Because we specified Depth First,
the toolpath is completed around one wall before rapiding over andmachining the other.

#6, Contour

The last operation will contour the inner pocket.
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1. Modify the existing
Contour process as
shown.

2. Turn on face selectionmode.

3. Select the faces of the angled pocket.

4. Create the toolpath and render.
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5. Save the part.

#2: The Hot Punch
TheHot Punch will only have one operation — a projected engraving operation. The part consists of
a stock body.Wewill create a text shape and project the contour toolpath onto themodel.

Part Setup

Document Control Dialog

1. Open the Hot Punch.vnc part. Set the global settings in theMachining Preferences tab of the DCD
as shown.

2. Ensure that the part has a Clearance value of 15mm.

Tool List

1. Create the following tool.

# Type Total
Length Diameter Corner/Tip #

Flutes
Flute
Length Material

1 3.15mmCenter
Drill 31.5mm 3.15mm 118° 2 1.9mm Carbide Solid

Creating Operations

#1: Engraving

Wewill create text and engrave the top face of the part. The contouring process provides for
centerlinemachining of all selected shapeswhich include text and artwork. Contouring
operation toolpaths can be projected on to sheets and bodies.

Wewill need to create text geometry that can bemachined. The system can create spline
geometry from any TrueType font. Youmay need to set the directory that contains the fonts for
your system. There is a Font Directory item in the Preferences>File submenuwhich allows you to
designate a directory that contains your system fonts. TheMoorpark TrueType font used in this
exercise is shipped with each order.
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1. Open the Text Creation dialog from the
Shape palette in the Geometry Creation
palette.

2. In the Text Flow tab select the clockwise arc.

3. In the Text Flow tab enter the information shown.

4. Click the Do It button to create the text.

If you have any problemswith text creation, refer to
the Text Creation Exercise in the Geometry
CreationManual.

5. Select the text geometry.
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6. Create this Contouring processwith tool
#1.

Whenmore than one shape is selected
prior to creating a contouring process, the
system automatically assumes that you are
doing engraving.When this is the case,
several of the items in the Contouring
Process dialog will be grayed out. The Z
Stock option is used in this case so that the
engraving toolpath will cut into the selected
body. The toolpath generated by the
operation will be shifted down along the Z
axis only by the amount specified. The
toolpath itself will be projected onto the
surface of the body and then will be shifted
down in Z to cut into the body.
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7. In the Solids tab enter the
information shown.

8. Ctrl+click themodel.

The text and themodel should both be selected.When 2D geometry and a solid or sheet are
selected for the cut shape of a process, the toolpath will be a projection of the 2D toolpath onto
the body or sheet.
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9. Create the toolpath

10. Render the operation.

#3: The Base
About the Part

This part is intended to help you become familiar with two important tools - the Profiler and using
constraint shapes and faces.

1. Open the part file Base.vnc.

This part has an existing stock condition and two groups of operations including two drilling
operations and a roughing operation. Drilling in 2.5D Solids, as with the standardMill package,
is accomplished with geometry or the HoleWizard so we do not need to go over the Holes
process.

The roughing operation uses a combination of containment faces to achieve the desired results.
Let’s look at how this works.
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Part Setup

The part should be ready for you to apply operations to it but to be safe wewill go over certain
aspects.

1. Ensure that the part is using a 5 Axis Vertical Mill
MDD, that the Clearance Plane is set to 350mm
and that the Global Settings in theMachining
Preferences tab are as shown.

The part has four tools as detailed below.

# Type Total
Length Diameter Bottom

Radius/Tip # Flutes Flute
Length Material

1 Drill 260mm 80mm 90° 2 n/a TiN Coated
2 Drill 260mm 40mm 118° 2 n/a TiN Coated

3 Rough
EM 121mm 25mm 0mm 3 45mm TiN Coated

4 Finish
EM 72mm 10mm 0mm 3 22mm TiN Coated

Machining the Part

Op 3, Roughing

1. Double-click operation #3.

2. Turn on Face Selection and deselect the
top flat face as shown.
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3. Redo (Ctrl+,) the operation.

The results are very different. By
deselecting the face we have told the
system that face is a constraint and we
cannot machine by it.

4. Reselect the top face and Re-do the operation to return it to its original state.

Ops 4-6, Rough and Contour

Wewill now create a roughing and contouring process group tomachine the angled face.

1. Switch to CS2.
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2. Create this roughing
processwith tool #3.

The Surface Z and Depth Z
values are acquired by
interrogating the top of the
circular boss and the large
flat angled face. If your
machining CS is set to
something other than CS 2
youmay get different
results.
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3. Create this contour processwith tool #4.
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As usual, the rotations information is automatically acquired.

4. Select All (Ctrl+A) the entire model, then deselect
the two faces that define the hole in the boss.

We have already drilled out this hole and we do not need to waste toolpath on it.

5. Create the operations.

You can see that we have some
toolpath that is not necessary. We
forgot to select the constraint
geometry.

6. Ctrl+double-click on the “air”
geometry and redo (Ctrl+,) the
operation.

These results aremore desirable.
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Op 7, Contouring with the Profiler

The last thing wewill do is use the Profiler to machine a selected area of the part. Operation #3
leaves stock on the rounded wall.

1. Switch to the XZ plane.

2. Activate the Profiler.

3. Turn off the Coordinate system grid.

You will find it easier to see and work with the Profiler if the CS grid is off.

4. Right-click the profile grid and choose Profiler Depth.

5. Interrogate (Alt+click) the face shown and Click the Apply button.

U
nf
ortunately at this depth the
Profiler does not see the
rounded wall. Wewill have to
manuallymove the Profiler.

6. Click anywhere on the Profiler’s grid
and drag the Profiler to a location in the
center of the rounded wall, as shown
above.
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7. Create a Contour processwith tool #4 as
shown.

The Final Z depth can be acquired by
interrogating the same face we tried to use
for the Profiler depth.
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8. Click the Profiler and set themachining
markers as shown, then create the
operation.

Youmay find it necessary to go to the Home view to get themarkers in the correct location.

9. Render the operations.

10. Save this part.
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PART PRINTS

Spherical Ellipse
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