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PLUG-IN TUTORIALS
This section provides an introduction to plug-in usage. There exists a separate tutorial for each
plug-in that should take only a few minutes to complete. These tutorials assume user familiarity with
part creation, machining, and posting parts; please review theGeometry Creation andMill tutorials
if you have not done so already.
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CLEANUP
This feature will delete duplicate points, circles, and lineswithin a given tolerance. CleanUpwill also
delete duplicate shapes (including splines) given that the shape is terminated at both ends (if it is not
open). The user simply selects which feature type (or types) to delete, sets the tolerance and clicks
theOK button. The systemwill keep the feature with the lowest number.

This exercise will introduce you to the use of the Cleanup Plug-in.

1. Open the part CleanUp.vnc.

Your screen will look like the image on the
right. There are 28 pieces of geometry, 7
lines, 4 circles, 3 shapes and 14 unconnected
points (some of which are coincident).

2. Choose CleanUp from the Plug-Ins>Geometrymenu.

3. Enter the values shown and ClickOK.
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Thismessage will be displayed, giving details of
what has been deleted. (Shown below in red.)

What was cleaned up and why?

1. The deleted (angled) line waswithin two degrees of another line.
2. Only one circle waswithin the Tolerance of another circle, as was the vertical line and

hexagon.
3. There were coincident points aswell as points within the general Tolerance.

CleanUp also deletes points that are used to terminate a deleted feature.

Therefore, the system returned themessage that more featureswere deleted than originally

thought. Use Edit> Undo to go back and experiment with tolerances and features.
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CREATE D-HOLE
This feature creates single- or double-sided DHole geometry. The geometry will be created at the
coordinates specified in the dialog at a depth of zero.The Create DHole plug-in does not require
any existing geometry--only an open part. All parameters are entered in a single dialog.

This exercise will introduce you to the use of the Create DHole Plug-in.

1. Create a new metric part D-Hole.vncwith the following dimensions: +X125, -X-125; +Y125, -Y-
125; +Z0, -Z-125.

2. Select Geometry> Create DHole from the Plug-Insmenu.

Wewill first create the geometry for a single-sided DHole with a 100mmdiameter and a 75mm
height centered at X-50, Y50. The flat will be 135°.

3. Enter the values shown.

4. ClickOK to create the D Hole.
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Wewill now create the geometry for a double-sided DHole. The hole will have a 100mm
diameter with a height of 50mm. The hole will be located at X50, Y-50 and be rotated 45°.

5. Select the double-sided DHole shape
and enter the values shown.

6. ClickOK to create the DHole.

Once a DHole has been generated, fillets or chamfers can be added to the corners. Remember
to save your part.
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CREATE SPIRAL
This feature creates spiral geometry whichmay then be used to generate spiral cuts. The geometry
will be created at the coordinate specified in the dialog at a depth of zero. The Create Spiral plug-in
does not require any existing geometry—only an open part. All parameters are entered in a single
dialog.

This exercise will introduce you to the use of the SpiralPlug-in.

1. Create a new metric part named Spiral.vncwith the dimensions+X50, -X-50; +Y50, -Y-50;
+Z0, -Z-25.

2. Select Geometry> Spiral from the Plug-Insmenu.

The spiral will be centered around the part’s origin. The spiral’s Outer Radius is 45mm, the Inner
Radius is 5mmand the offset between revolutions is 5mm.

3. Enter the parameters as shown and clickOK.

When viewed from the isometric view, your screen will look like the following image. Note that
the geometry is centered around Z0.
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This spiral is now ready to bemachined. If you were to apply a Contouring process to the
geometry, specify the depth you’ve got a spiral cut. If you have SolidSurfacer, the toolpathmay
be projected down onto the part.

Wewill now create a spiral with existing geometry.

4. Delete the geometry.

5. Select Mouse Line from the Line sub-palette in the Geometry Creation palette.

6. Switch to Home view.
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7. Create geometry similar as shown.

Be sure the geometry does not cross X0 (or the Y axis) as the shape will be revolved.

8. Select the geometry and choose Spiral from the Plug-insMenu.

This will open the Spiral Generation Parameter dialog, which hasmore options than the Create a
Spiral dialog we used earlier.

9. Enter the values shown and
clickOK.

10. Delete the line segment for a better view of the spiral.
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A spiral shaped with the profile of the selected geometry.
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TAPER THREAD
This feature creates the geometry for a tapered thread. The geometry will be created at the
coordinates specified in the dialog. Prior to selecting Tapered Thread, one or more points and/or
circlesmust be selected as the centerpoint of each tapered thread. The tapered thread will be
projected downward from the Z depth of the selected feature(s).

The Tapered Thread plug-in requires existing geometry. The part must contain point(s) or circle(s)
that define the location of the thread(s).

This exercise will introduce you to the use of the Taper Thread Plug-in.

1. Create a new metric part named Taper Thread.vncwith the dimensions+X50, -X-50; +Y50,-Y-
50; +Z0, -Z-200 using the 3-Axis Horizontal Mill MDD.

2. Create a single point at the part’s origin (X0 Y0, Z0) to function as the thread location.

3. Select the point you just created.

4. Select Geometry>Taper Thread
from the Plug-Insmenu.

The thread will be generated largely from the information in the National Pipe Thread library that
is built into the Tapered Thread feature.
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5. Click theNPT Table...
button

and select the
101.6mmNominal
Pipe Size as shown
below and clickOK.

Wewill modify the settings of the thread in order to get a better look at the tapered geometry.

6. Enter/modify the thread’s
parameters as shown in the
following image and clickOK.

The geometry is now ready to bemachined. Be sure to save the part.
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GEOMETRY PLUG-INS
TheGeometry Plug-ins consist of a subset of functions for working with geometry, most of which
have to do with breaking geometry into smaller components.

This exercise will introduce you to the use of the GeometryPlug-in.

1. Open part GeoTools.vnc from the sample part files.

Wewill now use theGeometry plug-ins tomanipulate the geometry.

2. Click the line segment to select it and then choose Geoedit Split from theGeometry Plug-ins
menu.
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You can use this dialog in two ways, At Parameter and Equally spaced. Equally spaced will evenly
divide the selected geometry into the number of segments specified.

3. This commandwill also work on arcs and circles.
Select the spline and choose the Equally spaced
option.

The geometry is now split into five equal segments.

Wewill now split geometry at a specific parametric value. For this youmust select an arc or line and
a starting point, and then enter either a decimal value or a fraction. The valuemust be between 0.0
and 1, and to begin with youmust select the end corresponding to the 0.0 value for the parameter.

4. Ctrl-click first the end point, and then the arc as shown.
Enter the following:
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There is now a new point at 5/8 along the length of the selected arc.

5. Now Ctrl-click the line and the lower end point. From the

geometrymenu choose Geoedit Extend. Enter the
following:

The line is extended by 40mmand because we checked the Connect box, the geometry is
automatically connected (blue connector point). This function will also work with curves.
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HSM PLUG-IN
TheHigh SpeedMachining (HSM) Plug-in will extend the toolpath and can put loops on the lace cut
toolpath, necessary for high speedmachining. This exercise will introduce you to the use of the HSM
Plug-in.

1. Open part HSM Tutorial.vnc from the sample part files.

2. Click on the Tool List and the Machining buttons.

The part file has the solid as shown on the left and
one tool, a 15mmball endmill. There are four pre-
defined operations that we will modify with various
HSMactions. In our first operation wewill extend
the strokes of our toolpath.

3. Double-clickOperation #1 to load the toolpath. Click the process to highlight it.

4. Select Toolpath> HSM from the Plug-Insmenu.

5. In the Settings tab, Check Extend Strokes. Wewill extend the start and end distances of our
current toolpath by 5mm.

6. Go to the Extend Strokes tab. Check and enter 5mm in the Extend Start and Extend End Distances
as shown here.
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7. Click the Do It button at the bottom of the dialog. Your screen will resemble the following
isometric view.

We now will change a rapidmove into a feedmove upon entering the part and add Z plane arcs
to the entry and exit moves on our toolpath.

8. Go back to the Settings tab. Uncheck Extend strokes and check Entry Feed Lines . Choose Entry
Feedrate from the pull downmenu. Now check On / Off Moves (Z Plane Arcs), and leave the
default No Feedrate Change on the pull-downmenu.
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9. Go to the Entry Feed Lines Tab and enter 10mm in the Line Length Text box as shown here.

10. Now go to theOn/Off Moves Tab. Enter the parameters shown in the following image.
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11. Click Do It.

Your screen will resemble the image shown below.

12. Return to the Settings tab. Deselect Entry Feedlines andOn / Off Moves. Check Lace Cut Step Overs
and Entry Feedrate from the pull-downmenu.

13. Go to the Lace Cut Stepovers Tab. Enter the parameters shown in the image shown here.

14. Click Do It.

Your screen will resemble the image shown here.
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15. Open the part Sharpcorners.vnc from the sample part files.

This part has geometry, a 20mm rough endmill, and three pre-defined operations that we will
modify with Sharp Corners in the HSMPlug-in.

16. Double-click the first operation.

17. Go to the Settings tab in the High SpeedMachining dialog. Check Sharp Corners and%age
Contour Feedrate from the pull downmenu.Wewill use 75%of our Contour feedrate.

18. Go to the Sharp Corners Tab. Enter the parameters shown in the image shown below. Click Do
Itwhen you are ready.
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Now wewill add Fillets with Multiple Radii to the sharp corners in our toolpath.

19. Enter the parameters shown in the image shown here.
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Your screen will resemble the image shown on the
right. A warning will appear that not all actions could be
completed. A look at the results tab will show sharp
corner warnings.
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MIRROR OPS
This featuremirrors selected geometry and toolpath. Select one or more ops and the Plug-in will
make copies of these with the toolpathmirrored in X or Y.

This exercise will introduce you to the use of theMirror Ops Plug-in.

1. Open partMirrorOpsTutorial.vnc from the sample part files.

2. Click on the Tools and CAM Palette buttonswithin Toolbar Commands.

We have three separate operations to illustrate
this Plug-in, one holes and two contour
operations. The exercise contains three tools: a
10mmand a 12mm rough endmill and a 12mm
drill. We have a closed shape, an open shape and
two points for drilling.

First, we will mirror the closed shape.

3. Double-clickOperation #1, then select

Plug-Ins> Mirror Ops.

For this operation wewill mirror the closed shape Horizontally. CheckingOne New Workgroup,
will create a new workgroup called “Mirror X.” Wewill replace the operation with our mirrored
operation by checking Replace selected operations. In this operation wewill keep the tool on the
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same side after our mirroring operation so check Keep Same Tool side. Your dialog will look as
below.

4. Click Do It.

The closed shape on your will look like the image
shown.

Now wewill mirror the two drill points.

5. Double-clickOperation #2, then select Plug-Ins>Mirror Ops.

Wewill mirror the two drill points Vertically. Checking Separate New Workgroups, creates a new
workgroup for each workgroup used by the original geometry and will add a new workgroup
Mirror Y. Check Replace selected operations. Your dialog should look as below.
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6. Click Do It.

The drill points on the screen will look like the image
shown.

For our next exercise wewill mirror our open shape Horizontally.

7. Double-clickOperation #3, then select Plug-Ins> Mirror Ops. Checking Use Same
Workgroups, will use our current workgroups. Check Replace selected operations and enter the
value shown below. Click Do It.
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The resulting toolpath will look like the image below.
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MODEL ASSOCIATIVITY
TheModel Associativity Plug-in allows you to associate toopath with a changed solid model. This
exercise will introduce you to the use of theModel Associativity Plug-in.

1. Open partModel AssociativityTutorial.vnc from the sample part files.

2. Click on the Tools and the Machining buttons.

We have two solids (one in the bodybag), one tool and one operation to illustrate this Plug-in.
Our original solid is shown below.

3. Double-clickOperation #1 to load your toolpath.
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4. Now select theModified Solid out of the Body Bag.

5. Launch the Solids> Model AssociativityPlug-in.

6. Enter the parameters as shown in the image below.

7. Click Do It.

You now have an updated toolpath that resembles the image shown here.
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Project Geometry
The Project Geometry Plug-in will project points, lines, and contour shapes onto bodies, modifying
their depth and/or shape as needed.

This exercise will introduce you to the use of the Project GeometryPlug-in.

Open themetric part named Project.vnc.
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Your screen will look like the
image on the left. As you can
see, the solid lies beneath the
plane at Z=0.

Project a point

Wewill now create a point at a depth of zero and then project that point down onto the solid.

1. Create a point at the origin ( - - ).

2. With the point and the solid selected, activate the plug-in by selecting Plug-Ins>Main Tools>

Project Geometry from the Plug-Insmenu.
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Accept the defaults on the parameters dialog
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The point now lies on the
solid.

Project a line

1. Delete the projected point. Change the view to Top view and using themouse line tool ( -

- ), create a line segment like the one shown below at a depth of zero.

2. With both the line segment and the solid selected, activate the plug-in by selectingMain

Tools>Project Geometry from the Plug-Insmenu. Please note this could take some time -
check the Progress on the progress bar at the bottom of the screen.
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Note that only the line
becomes projected while
the endpoints remain where
theywere.

Project a curve

1. Delete the projected line and extraneous endpoints. Switch toWorkgroup002, which contains
an open contour.

2. With both the contour and the solid selected, activate the plug-in by selecting Project Geometry
from the Plug-Insmenu.

3. Change the Settings Segment length to as shown below:
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Your screen will resemble the image below.
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REPORTER
Reports that are customized to the needs of your business can be very helpful to your records and
operations. This exercise provides an introduction tomaking custom reports. Please note that to
add Reporter templates to the GibbsCAM folder youmust have Administrator access to the
computer.

The report we will make is relatively simple, and is a combination of the existing Part andOperation
Reports. The report will not be as detailed as either report, but will provide amore complete
overview of the part.

This exercise will consist of customizing an Excel file (theModel file) and generating the text with
the desired commands for the report (the Template file). For example files that match this exercise,
see Plug-Ins/Tutorial Files - Required/Production/MillSampleMaster.xls and Plug-Ins/Tutorial Files -
Required/Production/MillSampleMaster.txt.

There are four steps tomaking a custom report:

1. Determining what functions you need in the report.
2. Making the ExcelModel file (the report’s layout).
3. Making the Template text file which contains the commands for the necessary functions.
4. Testing the report.

Step 1
Included in the report will be:

the user’s name the current date the name of the part

the units of measurement the stockmaterial themachine type

the post processor the NCF file name themin andmax values

the overall part size the operation number the operation type

the cut type the depth of cut the tool numbers

the tool’s diameter the type of tool the tool’s CRC number

a graphic of the start and end condition of each operation

Step 2
Wehave a partially completedModel file that you will need to complete. The file consists of all the
labels for the items to be output in the report and their position. You will learn how to enter certain
items and format the Excel document to make it more presentable.
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If you needmore information on working with Excel, try the program’s online help feature or look
through the following websites for tips:

• http://www.microsoft.com:80/office/excel/using/default.asp

• http://www.j-walk.com/ss/excel/index.htm

1. Open ReporterTutorial.xls (located in the Parts folder).

Most of the document has been formatted; however, there is still somework to do. The first thing
wewill do is change the user name to your name.

2. Select cell B2 replace Enter Namewith your name.

Simply select the cell and type. Theremay be some instanceswhere you will need to enter
information in the Formula Bar. The Formula Bar is located directly below the toolbar(s) and will
display any text entered in a cell.

The next thing wewill do is center the title over the width of the spreadsheet.

3. Select cells A through L on the first row. Click theMerge & Center button in the
Home/Alignment tab.

The result will look like the following image.

Wewill now enter calculations the report will perform. This will include automatically inserting
the current date and determining the overall stock size from theMin andMax values in a part’s
Document Control dialog.Wewill start with the current date.

4. Select cell F2 and in the Formula Bar enter =Now() and click .

http://www.microsoft.com/office/excel/using/default.asp
http://www.j-walk.com/ss/excel/index.htm
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The report will automatically return the current date and time. To enable this to be displayed
correctly, select cells f2 and g2 and choose Home>Cells>Format>Format Cells and in the
Alignment Tab, check theMerge cells option.

Next we will calculate the part’s stock Length.

5. Select cell H7 and enter =(B8-B7) and click .

N0w wewill calculate the part’s stockWidth.

6. Select cell J7 and enter =(D8-D7) and click .

Next is calculating the part’s stockHeight.

7. Select cell L7 and enter =(F8-F7) and click .

The next step will be to duplicate the operation data section of the report. The report will need a
complete duplicated section for each operation in a part. For the purposes of this tutorial,
duplicating this section twice will be sufficient.

8. Select cells A9 through L16. Copy this data by using Ctrl+C or choose Home>Clipboard>Copy
from themenu. The cells will now be highlighted, as shown.

9. Select cell A17 and paste the selected data by using Ctrl+V or choose Clipboard>Paste from the
menu. Once the first duplicate section has been pasted, select A25 and paste the data again.
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Note that rows 24 and 32 aremuch taller than row 16.We need tomake these rows thinner.
The width of rows and columnsmay be adjusted by clicking on the title line and while holding the
mouse button down, dragging themouse until the desired size is shown.

10. Click the number 25 on the left title line and drag themouse slightly upward until the right arrow
becomes a crosshair (as shown below) then click and drag this crosshair upwards until you
have resized its height to 3.00. Repeat this process on row 33.

A shortcut to modifying the cell size is to select entire cell rows instead of cell ranges. Thus, if
rows 17 through 24 were selected and pasted, the cell size formatting would be automatically
adjusted.

TheModel file is now complete.

11. Save this file as an Excel workbook ReporterTutorial.xlsx in the following location: C:\Program
Files\CAMBRIO\GibbsCAM\ <version> \Plugins\Data\Report\ReporterTutorial.xlsx
TheModel (xlsx) and Template (txt) filesmust have the same name and be saved in the correct
place.

Leave the Excel file open; we will be referencing back to theModel file for the rest of this tutorial.

Step 3
Wewill now create the Template text file. Wewill use Notepad to generate the file in this exercise,
but any text editor or word processor may be used.

1. Launch Notepad. Notepad can opened from the windowsStart menu.

Wewill start with several commands that are essential to all Template files.

2. Type UseNewImageOffsets and click . This commandmakes it much easier to place
any pictures you wish to add to reports.

3. Type SetPage 1 and click .

This designates that the following data will be output onWorksheet 1 of the Excel file. In the
default Plug-In reports, Mill data is output on a separateWorksheet from Lathe data to organize
informationmore efficiently.

4. Type SetPartExpandMode 1 then click .

This designates that the template will be outputtingMill part commands.
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5. Type SetOpExpandMode 1 and click .

This designates that from this point on, the template will output Mill operations only. The
SetPartExpandMode commandmay be usedmore than once in a template. You would enter a 2
for Lathe operations only or 0 for all operation types.

The above commands are common to all templates. Their exact order in the file is not important.

Wewill now enter commands to output the name of the part and the name of theMDD used in
the part. Wewill be referencing theModel file and specifying where to display the results.

6. Type PartName 2 10 in the Template file then click . Be sure to put a space between
the two and the ten.

7. Type PartMddName 3 2 in the Template file then click . Be sure to put a space between
the three and the two.

We have specified that the output for the part name should be placed two rows down and ten
columns over. The output for theMDD Name is one row down from that, which is three rows
down and two columns over. The Excel file cells would be J2 for the PartName output and B3 for
the PartMDDName output.

The image below shows an Excel spreadsheet. The two numbers in each cell represent the
numbers used in the commands of the Template file to place data in that particular cell. Note
that merging cells does not change their numbering.

Wewill now enter twomore lines of data. These commandswill specify the stock alloy and the
post processor to be used for the part.

8. Type PartFamily 3 6 in the Template file then click . Be sure to put a space between
the three and six.

9. Type PartPost 3 10 in the Template file and then click . Be sure to put a space
between the three and ten.
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We have specified that the output for "material" should be placed three rows down and six
columns over. The output for the "post processor" is four columns over from the stock alloy,
which is three rows down and ten columns over.

Next we will enter the commands for the units of measurement, the name of the NCF file
generated from the part, and any comment in the Document Control dialog.

The units command is not generated by text input from the user, but is handled internally by the
system. These types of commandswill output a number (for example, 1 for metric and 2 for
inches). Since numbers rarely havemeaning to the user, we use theMapString command to tell
the system to replace the numbers with somemeaningful text. TheMapstring command is
always entered just before the command it relates to. In this case we are defining the output for
the PartUnit command.

10. Type MapString "Metric" "Inch" in the Template file then click . Be sure to put a
space betweenMetric and Inch.

When the units of measurement for the part are output, the systemwill replace a 1 with the word
Metric and the number 2 with Inch.

Termsmust be separated by spaces. If a term consists of more than one word, it must be
surrounded by quotationmarks eg. (MapString “Rough Endmill”).

11. Type PartUnit 4 2 in the Template file and then click .

12. Type PartOutput 4 10 then click .

13. Type PartComment 5 2 then click .
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We have specified that the units of measurement will be placed four rows down and two
columns over. The PartOutput commandwill place the name of the NCF file generated by this
part four rows down and ten columns over. The PartComment commandwill place text from the
Comments section directly below the units of measurement (five rows down and two columns
over).

Wewill now enter commands for the custom report to output the stock dimensions as defined in
the Document Control dialog.We need to specify themin andmax values for X, Y and Z. The
Model file will take this data and calculate an overall size.

14. Type the following commands in the Template file. Be sure to click between entries so
that they are on separate lines.

PartMinX 7 2 PartMinY 7 4 PartMinZ 7 6 PartMaxX 8 2 PartMaxY 8 4
PartMaxZ 8 6
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The PartMinX commandwill be output seven rows down and two columns over. The Xmin value
goes in B7.

You will recall that earlier in this exercise when we set up the spreadsheet, we set up cellsH7, J7
and L7 to calculate the part size from the inputs in cells B7, B8, D7, D8, F7 and F8.

Wewill now enter the commands to output information from each individual operation. We
begin with the operation number thenmove on to the type of operation, the type of cut used in
the operation and the cut depth.

15. Type OpNumber 9 5 8 0 in the Template file then click .
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This is the first commandwe have come across that has four numbers for the position. The last
two numbers are for multiple results from the same command, in this case, the Operation
Number. For all successive operations the Operation Number will be output eight rows down
and zero columns over. You can confirm that this is the correct amount bywhich to offset
additional operations by counting the number of rows in theModel file that are given to each
operation. Start at row 9, which contains Start Condition, Op # and Tool #. Count the number of
rows between this row and the next time these items show up in theModel file.

Wewill now enter the command to output the type of operation used for a given operation
number. Wewill use theMapString command to output text instead of a number.

16. Type MapString "Drill" "Contour" "Pocket" "Thread Mill" "Surface" "No Op"

then click .

17. Type OpMType 10 5 8 0 then click .

Wewill now finish entering the operation data. Included is aMapString command for the type of
cut (Climb Conventional or Center Line) and the final cut depth of this operation.



Reporter

47

18. Type MapString "Climb" "Conventional" "Center Line" then click .

19. Type OpCutType 11 5 8 0 and then .

20. Type OpDepth 12 5 8 0 and then .

Wewill now enter the commands to output information on the tools used in the operation. This
includes the tool number, the diameter of the tool, the type of tool and the tool’s CRC#. Please
note that these are a special class of commands combining Tool Commandswith Operation
Commands.

21. Type OpToolNumber 9 8 8 0 .

22. Type OpToolDiameter 10 8 8 0 .

23. Type the following text and press when you are done. (NB if you are using a screen-
based version of the tutorial, you can just copy the list below and paste it straight into the text
file.) There are no carriage returns in the list.

MapString "REM" "FEM" "BEM" "Shell Mill" "Face Mill" "Key Cutter" "Drill"
"Center Drill" "Spot Drill" "Bore" "Tap" "Countersink" "Reamer" "Spot
Face" "Fly Cutter" "Single Point Thread Mill" "Back Bore" "Rigid Tap"
"Roundover" "2D Form" "3D Form" "Full Profile Thread Mill" "Lollipop"
"Convex Tip Mill" "Barrel Mill" "Dovetail" "Inserted Mill" "Custom Mill"
"80 Deg Diamond" "55 Deg Diamond" "35 Deg Diamond" "Round" "Square"
"Triangle" "Trigon" "Pentagon" "Parallelogram" "Rectangle" "Groove"
"Cutoff" "Thread N" "Laydown Thread" "Profile VN" "2D Form" "3D Form"
"Utility Tool" "Custom Lathe" "Unsupported"

Typing Shortcut

Youmay find it helpful for any future Reporter work to open the online Help in
GibbsCAMand go to the Plug-ins>Advanced Reporter Use> Commands pages.
There, you will find lists of commands available to reporter with a brief description of
what they do. At the bottom of each of the pages there are various lists that can be
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used in conjunction with Mapstring commands. Simply copy the required list and paste
it straight into the text file you are editing.

24. Type OpToolType 11 8 8 0 .

25. Type OpToolCRCReg 12 8 8 0 .

Wewill now enter the last set of commandswhich will output two images. The
UseNewImageOffsets command that we inserted in step 1 of the tutorial, enables us to position
an image using the four positioning specifiers that we have already been using to insert data, ie.
First, row and column number of the first occurrence, then number of rows and columns to
increment between subsequent data.

For graphics we can also specify vertical and horizontal offsets from the top and left of the cell. If
nothing is entered, or the value entered is too great, a value of 0 is used, placing the image at the
cells top left margin.

26. Type PictSize 100 75 .

This command specifies the width and height of a graphic in pixels. To prevent pictures from
being distorted, keep the numbers in a 4:3 ratio, such as 120x90 or 100x75.

27. Type OpSRender 10 1 8 0 .

28. Type OpERender 10 10 8 0 .

These commands specify where to place the start and end conditions of the stock for each
operation. Notice we have not specified offsets as these are not necessary in this particular
case.
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29. Save this file as ReporterTutorial.txt in the directory C:\Program Files\CAMBRIO\GibbsCAM\
<version> \Plugins\Data\Report\ReporterTutorial.txt

Step 4
The Template file is complete. Wewill now test it.

1. Open the part named ReporterTutorial.vnc. This was installed with the Tutorial Parts.

2. From the Plug-Insmenu select Reporter. In the Report type dialog, check Custom and
select ReporterTutorial.txt. The default output file is D:\Users\report.xlsx this is OK for the tutorial
purposes. Now clickOK.

The systemwill automatically activate cut part rendering for the part. When the rendering is
complete, the systemwill launch Excel and generate the report.

If you look at the report, you will see that we have a problemwith the graphics - the graphic
could be larger and is positioned too far over to the top left of the cells, and also the right hand
graphic seems to occupymore space than the left.
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3. Open the ReporterTutorial.xlsx Excel file. You will notice that the columnwidth of Column J is too
narrow - change the width to 11.86 by clicking into the divider between column title J and K and
drag the divider to the correct width.

4. Open the ReporterTutorial.txt file. Change the PictSize entry to PictSize 175 100.

We also need tomake
sure to specify the
horizontal and vertical
position.

5. Change theOpSRender entry to OpSRender 10 1 8 0 10 25.

6. Change theOpERender entry to OpERender 10 10 8 0 10 25.

7. Be sure to save the text file.

8. Rerun the report. Youmay get the error message The process cannot access the file because it is
being used by another process. This is because you still have the report.xlsx file open. Close it and
try again.

The graphics will now lookmore centered.

The Excelmaster file can hold up to 100 operations (the operation data fields in the Excel file
must be duplicated 100 times). Youmight find this report helpful for most parts.
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SOLIDS ALIGNMENT
The Solids Alignment Plug-in allows you tomanipulate the positions of solid models. The
positioning is done by rotating/translating the first of the two selectedmodels. The solid that was
selected first becomes aligned to a secondmodel. Cylindrical bodies can be aligned bymaking
them concentric. Further functions are provided to align bodies using two edges or two points. Once
two bodies have been aligned, additionalmodelsmay be selected and aligned using the same
transformation, enablingmultiple models to be aligned.

1. Align Two
Faces

2. Align Two
Edges

3. Flip About A
Face

4. Move/Rotate
5. Face-To-Face
Mate

6. AlignWith CS

This exercise will introduce the user to manipulating the position of solids using the Solids
Alignment plug-in. In this case, we will use the plug-in to correct the position of a part in relation to its
fixtures.

1. Open part SolidAlignment.vnc from the sample part files.

The slot block and fixtures are out of place due to errors during importing. Wewill now use the
Solids Alignment function to correct this.

2. Open Solids> Solids Alignment from the Plug-Insmenu.
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The file AlignModeless.dlllmust be in the Program
Files\CAMBRIO\GibbsCAM\<yourversion>\Plugins\Solids folder.

The first thing wewill do ismatch up the fixture bodies.

3. Select the two faces shown and click the Face-to-FaceMate button .

Make sure to select the faces in the order indicated since the first body ismodified to
accommodate the second.
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This aligns the fixtures.

Wewill now rotate the slot block body to align
with the fixtures.

4. While in Edge Selectionmode, select the two edges shown in the order indicated.

5. Click the Align 2 Edges button .
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6. Select the two faces shown and click the Face-to-FaceMate button .

The two faceswe are aligning are the front face of the slot block and the back face of the
foremost fixture. This will slide the part in the –X direction to align with the fixture.

7. Select the two faces shown and click the Face-to-FaceMate button.

The two faceswe are aligning are the right face of the slot block and the left face of the rightmost
fixture. This action will slide the part in the –Y direction.

8. Select the two faces shown and click the Face-To-FaceMate button. Select Shrink Wrap
from the Viewmenu to fit the stock boundaries to the part.
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The two faceswe are aligning are the bottom face of the slot block and the top face of the fixture
plate. This will move the part down along the Z axis to lie on the fixture plate.

The slot block part is now in place in relation to the fixtures.
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TP TRANS
This Plug-in allows you tomodify the location, orientation, and size of selected toolpath. Operations
may bemoved in X, Y and Z, rotated, mirrored, and scaled. The toolpath is duplicated when it is
transformed and an operation is created for each instance of the toolpath.

This exercise will introduce you to the use of the TP Trans Plug-in.

Wewill start with one simple pocket and translate, rotate, mirror, and scale the toolpath.

1. Open part Transform.vnc from the sample part files.

1. Click on the Tools and the Machining buttons.

This part has one existing operation and one geometric shape that is pocketed by this operation.

2. Double-click the operation to load the toolpath.

3. Select TpTrans from the Plug-Insmenu. The TransformOps dialog appears.

4. Select Translate and enter the values shown in the following image.

Wewill be translating (and duplicating) the toolpath down and to the right of the existing pocket
so that the additional pocket’s upper left-hand corner is near the arc of the first pocket.

5. Click Do it.
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Your screen will look like the image below. Keep the TransformOps dialog open. You will notice
that the operations are all highlighted.

If you look at
Operations in the
operation list, you will
see that the two
operations are
grouped, indicated by a
plus sign.

With the operations selected, we will now duplicate and rotate the existing toolpath.

6. In the TransformOps dialog, select Rotate and enter the values shown in the image. Click Do it.

Your screen will look like the following image.
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Wewill now duplicate andmirror the toolpath to complete this exercise.

7. SelectMirror Horizontally and enter 0 for the H coord. Click Do it.

We now have eight grouped operations in the Operation List and the toolpath has been
duplicated symmetrically around the part. When rendered, your part will look similar to the
following image.
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CONVERT TO TROCHOIDAL TOOLPATH
(OP MODIFIER)
This exercise will introduce you to creating Trochoidal Toolpath.

1. Open part Trochoidal.vnc from the sample part files.

This part currently contains two tools, three geometric shapes and a stock body defined through
geometry. First, we will create a Contouring operation to go around the inside pocket of the
stock. This will be the first set-up operation.

2. Create this Contour processwith Tool #1.

3. Set themachiningmarkers as shown on the smaller ellipse.
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4. Create the toolpath.

Wewill now create Trochoidal Toolpath from the operation.

5. Select the smaller tool #2, and the Contour operation we created, Right-click the operation
and chooseOperationModifiers from themenu, then choose Convert to Trochoidal.

6. Select the Full-Circle option and enter an offset of 2.5mm. ClickDo itwhen you are ready.

The Contour operation ismodified to the trochoidal parameters.
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During rendering, you will notice how the Trochoidal Toolpath is effectively scooping out the
inner shape from the stock. Trochoidal Toolpath is able to simulate large cuts by performing a
series of small, fast cuts.

Wewill now create a Roughing operation to pocket out the rest of the part.

7. Create this Rough processwith tool #2.
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8. Select the larger ellipse and the outer geometry.

9. Create the toolpath.

Wewill now modify this toolpath to a Trochoidal toolpath.

10. Select tool #2 and the Roughing operation we created, the operation and chooseOperation
Modifiers from themenu, then choose Convert to Trochoidal.

11. Again wewill use the Full-Circle option with a 2.5mmoffset. ClickDo itwhen you are ready.
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A new Roughing operation is created. Double-click the new operation; your screen should look
like the image below.

When rendered, you can see just how wide a groove this type of operation is able tomake.
While a 10mm tool would cut a groove that is just as wide, the smaller tool will provide for more
accurate corners.

When fully rendered, the part should look like the image.

Once the operations are complete, youmay delete the setup operations. However, it is
recommended that you not do so until you are sure you have the desired Trochoidal Toolpath.
Remember to save your part.
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STOCK WIZARD

The StockWizard helps to create a rectangular or cylindrical stock definition with or without a single
hole, rather thanmanually creating it. The holemay be a rectangular or circular shape. The hole in
the stockmay be a blind hole (a pocket) or a through hole

This tutorial is intended to illustrate the operation of the StockWizard and familiarize you with its
use. In this exercise wewill make a cylindrical stockwith a rectangular blind hole but will start out
creating a cuboid stock to illustrate changing the stock.

Please Note: The StockWizard was not designed to work with spinning Part Stations.

Defining Stock
1. Create ametric 3 Axis Vertical Mill part with the following workspace stock size:

+X: 175 –X: -175, +Y: 175 –Y: -175, +Z: 0 –Z: -75

This will provide a workspace large enough to visualize the new stock.
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The Z values in this dialog are critical to the StockWizard. The depth value of the stockwill be
taken directly from this dialog. All other settings for the stock sizemay be adjusted in the Stock
Wizard dialog but the stock depth is defined in and controlled by the Document Control dialog.

2. ChooseMain Tools> Stock Wizard from the Plug-in Menu.

Cuboid

When the StockWizard is first opened you can choose tomake a Cuboid or Cylinder shaped stock.

1. Click the Cuboid button.

This will make a cuboid shaped stock and progress to the next step where wewill define the size
of the stock.

2. Enter the values shown and click theNext button.



StockWizard

66

The stockwill always be equal to or less than the workspace defined in the Document Control
dialog and the depth of the stock is always equal to the Z values in the Document Control dialog.
The StockWizard definition will always override the Document Control dialog.

In step 3 wewill define the shape of a rectangular hole in the stock.

3. Select the Rectangular hole type.

Blind Rectangular Hole

Wewill create a blind hole in the stock. Holesmust always be contained within the X and Y
bounds of the stock. If the hole overlaps the stock no hole will be produced.

1. Enter the values shown to define the size of the blind hole and click the Finish button.

Rectangular holes can be placed anywhere within the stock boundary.
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2. View the stock in renderingmode (F6).

Cylindrical

Wewill now recreate the stock to be a cylinder with a depth of 100mm. Doing so will illustrate how
the workspace size will change.

1. Modify the workspace stock size as shown.

To change the depth of the stockwemust modify it from the Document Control dialog.

2. Open the StockWizard and select Cylinder for the stock shape.
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3. Define the cylindrical stock as shown and click theNext button.

Note that the radius of the stock is greater than the workspace.

4. Select a rectangular hole shape.
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The StockWizard has kept the hole size from the previous stock definition.

5. Change the depth of the hole to -75 and click the Finish button.

6. Open the Document Control dialog.
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Note that the X and Y values have beenmodified to accommodate the stock.

7. View the stock in renderingmode (F6).



Distribution Only Tutorials

71

DISTRIBUTION ONLY TUTORIALS
Distribution Only plug-ins are items that were developed to fit a particular need andmay be of use
elsewhere. These items often do not adhere to the GibbsCAM look and feel and are not considered
a normal part of the system.

Get Section

TheGet Section Plug-in is generally used with
solid Lathe parts to extract a flat profile of
geometry for machining.

This exercise will introduce you to extracting
geometry with the Get Section plug-in.

1. Open part Get Section.vnc from the sample part files.

2. Select the solid and choose Solids>Get Section from the Plug-Insmenu.

3. Select HV Plane and the Positive side and clickOK.

The system has extracted geometry from the intersection of the solid and the HV Plane (the
current CS), which in this case is the XZ Plane. Because the Positive option is selected, the
systemwill only extract geometry from the positive side of the V (or X) Axis.
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4. Delete the extracted geometry.

Wewill now extract geometry from the HD Plane.

5. Select the solid and choose Get Section from the Plug-Insmenu.

6. Select HD Plane and theNegative side and clickOK.

The system has extracted geometry on the negative side of the D axis from the intersection of
the solid and the HD Plane (plane perpendicular to the current CS).
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Deburring Process
The Plug-in cleans up selected edges of parts. This exercise will introduce you to the use of the
Deburring Process Plug-in.

First, ensure that “Deburring Process” is enabled within the Plug-In Manager.

1. Open part Deburr.vnc.

Wewill use the Deburring Process to clean up the inside and outside edges of the four circular
holes on the side of the part.

2. Select and drag the form tool provided onto Process #1 and select Deburring . (You

can also use a lollipop tool for this process .)

This opens the
machining palette and
creates a process tile

.

3. The Process dialog opens. Enter the values shown below.
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4. Ensure Face and Edge selection are enabled and select the outside face and one of
the outside edges of the circular holes as shown.

5. You will notice that the Do-it icon is now available on the Process dialog. Click this to create the
toolpath.

The toolpath will look like this.
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6. Deselect the operation in the operation list. Select the outside face and edge of the next hole.

Click Do it.

7. Using the same selectionmethod, create a deburring operation for the other two outside edges
of the circular holes.

8. Use the same selectionmethod to deburr the inside edge by selecting the inside face and one of
the inside edges of the circular holes.

9. Repeat the procedure for each of the three remaining inside edges.

Remember to deselect the operation tile immediately after you create it so the next operation
doesn’t overwrite the previous one. You will now have a total of eight separate deburring
operations.

10. Render the operations.

11. Save the part.
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