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Introduction
Data Exchange describes all forms of import and export that are available to you. Althoughmany
options are available, your package is limited to the options purchased.

Data Exchange can be used in several ways:

• Directly read geometry, surface-model, and solid-model formats generated by other CAD
packages.

• Use CAD Add-Ins that provide for the direct transfer of parts from their native program.

• Import and interpret attributes (such as colors or Hole features) generated by another package.

• Add files to amodel by importing.

• Sendmodels to other formats by exporting.

Several method for exchanging files in many formats are available. Models can bemodified in a
previous version of GibbsCAM, on another computer, or even on another program.

This guide assumes a level of proficiencywith geometry creation, coordinate systems, and basic
machining. Before reviewing this document, you should already be familiar with the basics of
GibbsCAMas outlined in Getting Started, Geometry Creation, andMill or Turning. Additionally, if
you will be using solids, it will be very helpful if you have a basic understanding of Advanced CS and
any of the solids packages (Solids Import, 2.5D Solids or SolidSurfacer).

Open/Import Formats Export Formats CADAdd-Ins

• ACIS / SAT (filetypes *.sat, *.sab, *.asat,
and *.asab)

• AutoDeskRealDWG (filetypes *.dwg and
*.dxf*)

• CATIA v4 (filetypes *.DLV and *.model) and
CATIA v5/v6 (filetypes *.CATPart and
*.CATProduct)

• CATIA v5/v6 Assembly

• PTC Creo Parametric Part (filetypes *.PRT
and *.PRT*) and Assembly (filetypes *.ASM
and *.ASM*)

• DWG

• DXF (filetype *.dxf)

• IGES (filetype *.igs)

• ACIS / SAT v6
through v29
(filetype *.sat)

• PTC Creo
Parametric ATB
(filetype *.neu)

• DXF
(filetype *.dxf)

• IGES
(filetype *.igs)

• Parasolid v8
through v31
(filetype *.x_t)

• point list
(filetype*.txt)

• Autodesk
Inventor

• CimatronE

• KeyCreator

• Mechanical
Desktop

• Rhinoceros

• Solid Edge

• SOLIDWORKS
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Open/Import Formats Export Formats CADAdd-Ins

• KeyCreator (filetype *.CKD)

• NX (filetype *.prt); also called UGS/NX

• Parasolid (filetypes *.x_t and *.xmt),
Parasolid binary (filetype *.x_b), and
Parasolid Partition (filetype *.p_b)

• point list (filetype *.txt)

• RhinocerosOpen Nurbs (filetype *.3DM)

• Solid Edge (filetype *.par) and Solid Edge
Assembly (filetype *.ASM)

• SOLIDWORKS (filetype *.SLDPRT) and
SOLIDWORKS Assembly
(filetype *.SLDASM)

• STEP AP203/AP214/AP242
(filetypes *.STEP and *.STP)

• STL (filetype *.stl)

• VDA-FS (filetype *.vda)

• STL
(filetype *.stl)

• STL binary
(filetype *.stl)

• STEP AP203,
AP214, AP242
(filetype *.STEP)

Name changes:

l Pro/ENGINEER: see PTC Creo Parametric
l Creo Elements/Pro: see PTC Creo Parametric
l SiemensPLM: see NX
l Unigraphics / UGS: see NX

Import version Export version Add-In version

ACIS R29 ACIS-SAT R29 Autodesk
Inventor

201 and
later

Autodesk
Inventor 2010 and later PTC Creo

Parametric Wildfire v5.0 CimatronE 11 thru 13

CATIA v5 R27 DXF KeyCreator 9,10,11
PTC Creo
Parametric Wildfire v5.0 IGES KeyCreator 12,13,14

DXF Parasolid v31 KeyCreator 15

IGES STEP (GRANITE v11) Mechanical
Desktop 2004
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Import version Export version Add-In version

NX 7.5 Mechanical
Desktop 2009

Parasolid v31 Rhinoceros 3.0
RealDWG 2018 Rhinoceros 4.0
Rhinoceros 3 through 6 Rhinoceros 5.0
Solid Edge ST9 Solid Edge ST9

SOLIDWORKS 2011 through
2019 SOLIDWORKS

2011
through
2019

STEP (GRANITE v11)
VDA-FS VDA-FS

Name changes:

l Pro/ENGINEER: see PTC Creo Parametric
l Creo Elements/Pro: see PTC Creo Parametric
l SiemensPLM: see NX
l Unigraphic/UGS: see NX
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Interface
This chapter describes the basic interface items that are specific to importing and exporting data.
The details of the interface for importing and exporting are covered below.

• File Extensions

• “FilesWithout Extensions” on page 10

• “File Import and File Export” on page 10

• “CAD Attribute Import” on page 10

• “Option Dialogs” on page 11

File Extensions
Every file should have an extension type that defineswhat
type of file it is. Native GibbsCAM files have a three letter
extension vncwhich stands for “Virtual Numeric Control.”
Parasolid files have different extensions depending on the
CAD program that was used to generate the file. For
example, Parasolid files generated in SOLIDWORKS have
the extension x_t. Parasolid files generated byUnigraphics
have an extension of xmt. Becausemany users and
applications change their extension name for various
designation reasons, GibbsCAMoffers a way to handle these
differences.

The File > Preferences > File Extensions dialog designates the extension for exchange files. In order to
open a file with a different file extension, the extension of the file to be importedmust match the
extension entered in this dialog. The default extensions for each type are contained in the dialog. To
add a file extension, use a comma to separate the values as shown in the Parasolid or Catia fields.

The extension displayed next to the file type in both theOpen part, Import, and Export dialogswill
match the extension entered in the File Extensions dialog. For example, if x_t is the only entry for the
Parasolid extension, it will only recognize Parasolid files with that particular extension.
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Files Without Extensions

If a file does not have an extension, the Open part file and Import dialogs can open such files even
though they do not have extensions or if they have the wrong extension specified. Simply type the
first few letters of the filename, choose the file from the drop-downmenu, set the file type, and click
theOpen button. The file will be opened as if it were labeled properly.

File Import and File Export
The import and export packages (including the Exchange option) provide the capability to transfer
model data from other CAD packages into GibbsCAM. The File > Import dialog lets you select the
type of file to be imported. 2D geometric and 3D model files can be imported into an existing file.
Imported geometry will be placed in a new workgroup. The new workgroupswill be viewed as
visible and inactive.

CAD Attribute Import
When you import models from other systems, CAD attributes are preserved. You canmapCAD
attributes to GibbsCAMuser attributeswhen you initially import themodel, or at any time thereafter
(using Features > Attribute Manager). When you import or reimport, you canmodify user attribute
definitions. For details, see CAD AttributeMapping.

TomapCAD attributeswhen importing a CAD model
1. Click File > Import and select a CAD model to import.
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2. In the Solid File Import Options dialog, select one or more solid file import options and
configurations. For more information, seeOption Dialogs.

3. In the Define CAD Attribute Map dialog, select one or more checkboxes for the CAD attributes
you want to map, and then clickOK.

CAD Attribute Mapping
When you import CAD attributes, you normally retain the system attribute name and attribute type
without changes. After a system attribute ismapped to a particular name and type, re-mapping
affects the attribute's values only, not its name or type.

Note: To re-map to a different attribute name or attribute type, youmust first delete the existing user
attribute.

System
Attribute
Type

New
Type Description

Integer Real or
Text

Each integer value is retained and translated. For example, the integer 1
becomes real 1.0000 or text string "1.0000".

Integer Color
The first 64 unique integer values aremapped to 64 different colors; the
next 64 unique integer values aremapped to the same set of 64 colors; and
so forth.

Integer Feature Each integer value ismapped to a new feature ID, but feature colors are
reused in cycles of 64.

Real or Text Integer The real or text values become undefined.
Color Integer White ismapped to 1 and other colors aremapped to 0.

Color Real (or
Text)

White ismapped to 1.0000 (or "1.0000") and other colors aremapped to
positive real values less than 1.0000.

Option Dialogs
When a surface or solid file is opened or imported, a dialog offers options for handling bodies.
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Filter and Info dialogs
Depending on the file types you open or import, additional dialogs provide you with more
information and control when importing or opening parts.

Translation
When you are finished entering information in the Import and Export dialogs, click on the Process
button. The translation dialog will appear on the screen to indicate that the file is being translated.
The progress for each type of element will be shown.
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Import
GibbsCAM import features provides a way to bring part models designed with different CAD
packages into GibbsCAM. This section details all of the importing capabilities of GibbsCAM.
Importing can be accomplished in two ways, by direct transfer (File > Open) or by adding amodel to
a pre-existing GibbsCAM file (File > Import).

Terms
Exchange
Any action that leads to accessing amodel from another application whether opening/importing or
using the associative transfer add-ins.

Feature
A piece of geometry; a point, line, circle, curve, etc. in an imported file.

Workplane
The 3D plane in which a specific feature was defined; similar to the use of coordinate systems in
GibbsCAM.

Level/Layer
A grouping of features. IGES files use the term “level” while DXF files use the term “layer”; similar to
workgroups.

Coordinate System
A plane in space with an origin and three axes (horizontal, vertical and depth). Every feature lies in
a coordinate system. For example, a point is a location in space defined by three numbers, a
horizontal coordinate, a vertical coordinate and a depth coordinate.

CS1
In amill machine CS1 is the coordinate systemwhere the horizontal, vertical and depth axes
correspond to the X, Y, and Z respectively. In a lathe, CS1’s horizontal, vertical and depth axes
correspond to X, Z, and Y respectively.

When importing files it is often necessary tomove the part origin. If there is a point at
the desired origin, the easiest way tomove the origin is to selectModify > Move Part
Originmenu and use the interrogate a point or enter the correct origin. More
informationmay be found in the CommonReference guide.

File > Open
File exchange in GibbsCAM is typically accomplished using theOpen dialog. If your system includes
solids (Solids Import, 2.5D Solids, and SolidSurfacer), an options dialog appears when you open
an imported file containing a body (in other words, a surface or a solid). Depending on the type of
file you open, this dialog lets you select amachine type, override the part units (millimeters or
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inches), and apply shrinkage and scale factors. It also offers options so that surface parts can be
automatically stitched (using the Solidify command), and bodies can be automatically simplified or
have unneeded topology removed.

Solidify
This option will attempt to convert a surfacesmodel into a solid model. If this function fails you can
use the Solidify function to attempt the solidify using other options.

Remove Unneeded Topology
This commandwill inspect selected bodies or faces for any unneeded elements. If two items share
the same underlying surface, the bodywill be simplified. This is identical to the command found in
the Solidsmenu.

Simplify
This command simplifies the geometry of a bodywherever possible. A bodywill be defined by lines,
circles, spheres, cubes, cylinders, and toruses instead of B-splines. This is identical to the
command found in the Solidsmenu.

Geometry-Based Files
The Exchange option allows geometric parts to be transferred fromCAD systems to GibbsCAM
using the Import command. Exchange enables the import (and export) DXF, DWG, IGES and Point
List files.

DXF
DXF is themost common geometry format in most CAD applications. DXF files can be imported
into a GibbsCAMpart or opened directly. DXF files are plain text files that can bemodified or
viewed with any text editor. It is often easier to edit someDXF problems in a text editor rather than
recreating or exporting the file again.

DXF Problems

If there is a problemwith a DXF file the first step would be to verify the contents by opening it in a
text editor. The file should look similar to the following:

0

SECTION

2

HEADER

...(DATA)...

EOF

Each file should have these entries and should end the file with the EOF (End of File) call.
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Files that appear as followsweremost likely created in a UNIX environment and are all but useless.
You should have the creator of the file re-export the file for Windows. This will convert line endings
from the UNIX format to a DOS format.

0SECTION2HEADER...(DATA)...EOF

Themajority of problems are simply amisuse of the file extension. Often DXF files are really DWG
or binary DXF files. Users often attempt to open compressed files with ZIP or EXE extensions by
renaming themwith a DWGextension. Sometimes the file may be received with these problems.
However. using the DWG filter will open renamedmost DXF files.

DWG
DWG (DraWinG) files can be imported into a GibbsCAMpart or opened directly. A DWG file is an
encoded version of a DXF file. Since DWG is a native format theremay be issues in newer
versions. For most uses, DXF is recommended.

About DWG and DXF

DWGandDXF files were developed by AutoDesk. DWG (DraWinG) is the native file type of
AutoCAD andDXF (Drawing eXchange Format) is a commonly usedmeans for exchanging
drawings between CAD systems. A DXF file ismuch larger than its DWGcounterpart and carries
with it some inconveniences. DXF files can not be synched for inter-operability, ensuring themost
recent updates to the file. DXF data can also be imprecise due to the smaller number of decimal
places, compared to its native DWGcounterpart. Knowing the details of the creation application will
make the data exchanging these formats easier.

Entity Feature Equivalent

POINT Point

LINE Line

3DLINE Line

CIRCLE Circle

ARC Circle

POLYLINE Connected Lines

3DPOLYLINE Connected Lines

Autodesk comment on DWG

“Since the AutoCAD drawing database (.DWG file) is written in a compact format that changes
significantly as new features are added to AutoCAD, we do not document its format and do not
recommend that you attempt to write programs to read it directly. To assist in interchanging
drawings between AutoCAD and other programs, a Drawing Interchange file format (DXF) has
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been defined. All implementations of AutoCAD accept this format and are able to convert it to and
from their internal drawing file representation.” (Autodesk)

IGES
IGES (Initial Graphics Exchange Specification) is supported bymanyCAD systems and is
published by the US Product Data Association.

The table shows the geometric IGES entities supported for importing from an IGES file. IGES files
are treated the same asDXF and DWG files with the same filters asmentioned previously.

Entity # Entity Name Feature Equivalent

100 Circular Arc Circle

102 Composite Curve Connected features

104 Conic Arc B-Spline

106 CopiousData Connected lines

108 Plane (Bounded; Form 1)

110 Line Line

112 Parametric Spline Curve B-Spline

116 Point Point

126 Rational B-Spline Curve B-Spline

130 Offset Curve B-Spline

Point List
A point list is a simple text file containing X, Y, and Z coordinates. (Note that Z coordinates are not
required for GibbsCAM to understand the list.) Each point should be on a line by itself. Delimiters to
separate the numbers can be tabs, spaces, or commaswith spaces.When creating the point list,
DONOT create labels for X, Y, and Z. The following example point list geometry is taken from
exercise #1 of Geometry Creation.

1. Space separated
values

2. Tab-separated
values

3. Comma+space
separated values

4. Z value not entered

Example of a point list file using various separators and the points it generates.
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Solid-Based Files
Solid file formats, such as Parasolid, are themost simplemethod for data exchange as systems
sharing the same technology do not require translation as do other file types. Solid models provide
amore complete and accurate part description. Solid modelsmay be opened or imported.When
importing, amodel will be added to the current file.

Parasolid

x_t and xmt Files

Parasolid files are native to GibbsCAMand there is no translation involved when they are brought
in. This is due to the fact that GibbsCAM is built with Parasolid technology, providing for a direct
reading of Parasolid information. GibbsCAM supports the flat assemblies option in Parasolid files,
but not hierarchical assemblies.

Solid Edge
If you have a copy of Solid Edge installed on your system, you can also transfer Solid Edge parts
and assemblies fromwithin Solid Edge. For more information, see “Solid Edge Transfer Add-In” on
page 35.

.PAR and .ASM Files

For opening and importing purposes, Solid Edge part and assembly files are treated exactly the
same as Parasolid files. If you open or import an assembly (.ASM file), all the parts (.PAR files) that
it referencesmust reside in the same folder.

SolidWorks

.sldprt Files

For opening and importing purposes,
SolidWorksmodels (v5.0 or later) are treated
exactly the same as Parasolid files. If you
have a copy of SolidWorks installed on your
system, see “SolidWorks Transfer Add-In”
on page 35.

SolidWorks files can containmany revisions
of a part. These revisions are referred to as
“configurations”. When a SolidWorks part is
exchanged, a list presents all available
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configurations, and a preview is available for each configuration.

Note that the File > Preferences dialog allows you to choose between translators: Solidworks, or
Spatial (a unit of Dassault Systèmes, and developer of the 3D ACIS kernel). Models imported by
the Spatial translator allow you to access PMI data created by SolidWorksDimXpert. If the
Solidworks translator is in effect, the Select Configuration dialog offers four checkboxes (A and B
in the illustration). If the Spatial translator is in effect, the dialog offers two checkboxes (A in the
illustration) and always imports imported bodies and features if the *.sldprt or *.sldasm file
contains them.

Autodesk Inventor

.ipt and .iam Files

Autodesk supplies a free viewer for opening *.iam or *.ipt files. For Autodesk Inventor 5 through
Autodesk Inventor 10, this wasDesign Tracking. For later Inventor formats, it is Inventor View.
Both are available as either a plug-in to Autodesk Inventor or as a free standalone application.

Autodesk Inventor software can be downloaded from http://www.autodesk.com/inventor.

GibbsCAM can import Autodesk Inventor solid model files only if the GibbsCAMworkstation has
installed the viewer plug-in or the standalone application.

Also, more specifically: To transfer or import Autodesk Inventor features into GibbsCAM, the level
of Autodesk Inventor or Inventor View must be 2014 or later.

You can store Autodesk Inventor features in a way that makes them understandable to GibbsCAM.

What Are Autodesk Inventor Features?

Autodesk Inventor defines several kinds of features: holes, extrusions, fillets, chamfers, and so
forth. Features in Autodesk Inventor part files (*.ipt) and assembly files (*.iam) can be
understood byGibbsCAM14, but only if theywere saved while the GibbsCAMCAD Transfer Add-
In for Autodesk Inventor was installed on the Autodeskworkstation.

Such feature data can sometimes be quite large, and it is not always needed. In GibbsCAM, you
can optionally set a switch that suppresses the importation of such feature data, using the Inventor
Options dialog box:

To open this dialog box: Plug-Ins > (Misc) > Autodesk Inventor Options
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Importing Autodesk Inventor Features

To import features stored in an *.ipt or *.iam file that was saved in Inventor while the GibbsCAM
CAD Transfer Add-In for Autodesk Inventor was installed, follow these steps.

Before you begin: On your GibbsCAMworkstation, youmust have installed either Autodesk
Inventor or Autodesk Inventor View, 2014 or later. (Note that Autodesk Inventor View is available
as a free download.)

1. File > Import; navigate to the Autodesk Inventor file and open it. The following sample file is
supplied: Pockets_with_Features.ipt

2. In the Solid File Import Options dialog, specify the settings you prefer.
3. In the information dialog, specify preferences for stitching and units and then click OK.

Result: The Define CAD Attribute Map dialog appears. (Note: This can take several minutes
if the file containsmany hundreds of features.) If the dialog does not appear, use Plug-Ins
menu option Autodesk Inventor Options as noted above to specify importation of features.

4.In this dialog, specify the types of Inventor features to import, and then click OK.
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5. To view andmanipulate feature data within GibbsCAM, use Features > Feature Manager.

IGES
IGES solid entities are also supported with GibbsCAM. The table shows the list of specific solid
entities that can be read by the IGES import filter.

Entity # Entity Name

186 Manifold Solid B-RepObject

502 Vertex

504 Edge

508 Loop

510 Face

514 Shell

Surface-Based Files
When surface files are opened/imported, they are displayed as sheets. Sheets are the graphical
objects used by the solid modeler to represent surface entities. Each surface entity will be
represented as a single faced sheet. When opening/importing surface files an option to solidify the
model is available.
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ACIS

.sat Files

SAT files can be opened directly byGibbsCAMwith the
SAT (ACIS) option installed; this option is included with
2.5D Solids and above. An initial scan of the entities in the
selected file will bemade before opening the SAT info
dialog. The SAT info dialog provides information on the
valid bodies contained in the file.

GibbsCAMwill read the SAT file to determine what it is and
where it came from. This information is contained within
the file’s header and will be displayed in the SAT info
dialog. Older SAT files do not have this header information.
Whatever information that can be determined will be
displayed in the dialog. The SAT dialog contains the size
specifications for the part model. SAT files are written in
generic units. It is not specified whether these units aremm, inches, miles, etc. The SAT dialog
which comes up when a SAT file is imported asks the user to indicate a conversion value for mm
per unit. If the units are inches, enter 25.4mm/unit. Clicking the in. button will automatically enter
this value in the conversion field.

Version
This is the ACIS version that outputs the SAT file.

Product
The CAD product used to create the SAT file.

ACIS Version
The version of ACIS the file was saved as.

Date
The date on which the file was created.

Distance Resolution
The distance (not in measurable units) between which any two points are coincident.

Angle Resolution
Theminimumdeterminable angle value based on distance resolution andmeasurement units.

Entities:
The total number of objects contained in the file. This can be just bodies or it can be bodies aswell
as extraneous information.

Valid Entities:
The total number of valid entities that GibbsCAM can read. The total may include invalid bodies.

Bodies
The total number of bodies that ACIS considers valid.
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Size Specifications for the Part Model
SAT files are written in generic units. It is not defined whether these units aremillimeters, inches, or
meters.

Un-Stitch Non-Manifold Bodies
This option is available to help importing some files. A bodymust have two faces connected at every
edge. More than two faces at an edge produces a non-manifold solid. By unstitching the body, the
file should be able to be imported without error messages. Disable this option if you want to try to
import the file directly.

User Defined Units:
The user is asked to define a conversion value for mmper unit. If the units are inches enter 25.4
mm/unit. Clicking on the in button will automatically enter this value in the conversion box. Be
sure that the unit of measure for a part is the same as that designated in the DCD (Document
Control dialog). If you do not know the original units of measure, make an estimate based on the
units shown in the dialog. This section will be grayed out if the units are specified in the header.

ACIS Imports
ACIS Mend Body and ACIS Auto HEAL are two preferences that can aid in solidifying imported
ACIS files. ACIS Mend Body is active by default and ACIS Auto Heal is not. For most part the
default setting or a combination of settings should work well onmost parts. If you have an ACIS file
that does not import properly, you should try disabling the ACIS Mend Body option. If that also fails,
then you should try activating the ACIS Auto Heal option. Note that importing with Auto Heal on can
takemuchmore time to import than with it disabled. For more information, see Common
Reference.

CATIA v4

.dlv and .model Files (Version 4)

If you purchase the CATIA product option, you can
import CATIA files into GibbsCAMusing File > Open or
File > Import. When a CATIA file is selected, the CATIA
Import dialog prompts you to select the features to be
imported and to designate Trim Preferences.

Because CATIA files can containmore than onemodel,
the dialog presents a list of models fromwhich you can
select. Once a CATIA Model Name is selected, the
Reference Coordinate Systemmust be selected. This is the
CS in the CATIA file that will correspond to the XY plane
in GibbsCAM. Options in the Trim Preferences area control the trimming of wireframe geometry.
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CATIA V5

.CATPart and .CATProduct Files

CATIA v5 parts are imported without a filter, using Spatial (a unit of Dassault Systèmes, and
developer of the 3D ACIS kernel).

Assemblies. The system can read CATIA v5 Assembly files (CATIA release 7 through release 23).
To open a CATIA Assembly, both the assembly and the individual parts it usesmust all reside in the
same folder.

Import options. The import options for CATIA v5 are less numerous than for v4, and you are not
prompted for CATIA-specific information.

IGES Surfaces
IGES surface files can be imported byGibbsCAM. It will attempt to create a valid single faced sheet
for each surface contained in the IGES file. However, degenerate surfaces can be created in
surface files because they are approximated.When a surface can not be created the imported the
ambiguous surfaceswill not be created and new surfacesmust be created to solidify themodel.

Entity # Entity Name

114 Parametric Spline Surface Entity

118 Ruled Surface Entity

120 Surface of Revolution Entity

122 Tabulated Cylinder Entity

128 Rational B-Spline Surface Entity

143 Bounded Surface Entity

144 Trimmed Surface Entity

Errors

GibbsCAMgenerates an error file when surfaces contained in an IGES file fail to import. An alert
will be produced, indicating how many surfaces failed to import and create an error log.
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KeyCreator

.CKD files

KuboTek KeyCreator files (.CKD files) can be imported when the SAT option is installed. Both
individual files and assembly files are supported.When an assembly file is imported, the systemwill
display the part info dialog for each component.

PTC Creo Parametric (Creo Elements, Pro/E
Wildfire)
Note: PTC Creo Parametric was formerly known asCreo Elements and as Pro/ENGINEER
(informally: “Pro/E”). Itsmaker, PTC Inc., was once known as Parametric TechnologyCorporation.

PTC Creo Parametric (Pro/E) files are available with the PTC Creo Parametric (GRANITE)
option. GRANITE is PTC’s feature-based geometricmodeling system. GRANITE uses the same
data that is at the heart of PTC Creo Parametric.

The About GRANITE Import dialog box (Plug-Ins > Misc > GRANITE Info) offers the following
controls:

l Import Step Feature IDs lets you specify that feature IDs (if present in the STEP-NC data) will
be imported asGibbsCAMattributes.

l Import Blanked Layers lets you specify that Creo geometry in a named layer will be imported
into a GibbsCAMworkgroup whose name is the same as the Pro/E layer name.
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.prt / .prt* and .stp / .step Files

The PTC Creo Parametric (GRANITE) option uses PTC’sGRANITE technology to open and
import native PTC Creo Parametric files — in other words, *.prt and *.prt* files. The STEP
(GRANITE) option allows you to open and import STEP files (AP203, AP214, and AP242).

.asm and .asm* Files

Although the PTC Creo Parametric (GRANITE) option lets you import PTC Creo Parametric
Assembly files, there are a few things youmay need to know in order for it to work as youmight
expect. The only time youmay need this is when you are attempting to import assemblies that
contain parts that are non-generic instances in family tables. To retrieve any non-generic instances
from a family table, GRANITE requires an instance accelerator file for the instance.

The following information on creating instance accelerator files is adapted from the Help file for
Pro/ENGINEER 2001.

Instance Accelerator Files

You can reducemuch of the time required to retrieve an instance of a part or assembly from disk by
saving instances in uniquely-named instance accelerator files:

l For parts, instance accelerator files are named instancename.xpr.
l For assemblies, instance accelerator files are named instancename.xas.

The system behavior in saving instances of parts and assemblies is controlled by a variable named
save_instance_accelerator. You can set up or modify the value of the variable either by using a
configuration file option or by using the PTC Creo Parametricmenu (File > Instance Operations >
Accelerator Options) to open the Instance Accelerator dialog box.

The save_instance_accelerator variable is set to one of the following values:

None (default)
GibbsCAM saves an instance only by saving the genericmodel and its Family Table.

Always
GibbsCAM saves an accelerator file when the instance itself is saved, either explicitly or
implicitly:

l The instance is explicitly saved when you open an instance in a new PTC Creo Parametric
window usingOpen in the Family Table, and then save the instance as a separatemodel file
using File > Save or File > Save a Copy in the PTC Creo Parametricmenu bar.

l The instance can also be saved implicitly through a higher level object, such aswhen you
save the entire model file using File > Save on the PTC Creo Parametricmenu bar.

Explicit
GibbsCAM saves an accelerator file only when the instance itself is explicitly saved. See the
preceding paragraph for a description.
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In addition to the None|Always|Explicit settings (located in the Using Options area) you can also
use the Instance Accelerator dialog box to do the following:

l Create an instance accelerator file
l Save instances of parts and assemblies
l Update the generic and all instance accelerator files
l Delete invalid instance accelerator files

STEP - AP203, AP214, and AP242
STEP files are imported using either of two data-exchange products: GRANITE (PTC's feature-
based geometricmodeling system), or Spatial (a unit of Dassault Systèmes, and developer of the
3D ACIS kernel).

.step and .stp Files

When a STEP assembly file is brought into the system, each component will lie in its own
coordinate system so that the imported data looks like the assembly. You canmachine themodel in
the local CS, or you canmove themodel to a different CS for machining.

VDA-FS

.vda Files

When a VDAFS file is selected and the Solid File OpenOptions are set, GibbsCAMwill immediately
open or import the file.
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Export

Geometry Export
GibbsCAMprovides the user with the capability to export geometry contained in a part file into
either DXF, IGES or Point list file formats. These files can then be opened by any program that can
read those file formats. Files are exported using File > Export. If the file containsmultiple
workgroups, those workgroupswill be split into different layers in the resulting DXF or IGES files.

The options include DXF, IGES and Point List file formats. A file name and location to save the file is
also entered in this dialog. GibbsCAMwill automatically enter an extension onto the file name
based on the file format. File extensions are set in the File Extensions preference.

DXF
When exporting to the DXF file format, the Export Filter
dialog will appear. The Features group designateswhat
features to export to the DXF file. If the Suppress Z button
is turned on, the exported DXF file will not contain any Z
values, producing a two-dimensional drawing. ManyCAD
packages that use the DXF file format only support 2D
drawing of geometry. The Units box is grayed out when
exporting to the DXF file format. DXF files do not make

any designation to units of measurement. GibbsCAMwill output the geometric values in whichever
working units are being used in the file. GibbsCAM imports the DXF entities shown in the following
table.

Entity Feature Equivalent

POINT Point

LINE Line

CIRCLE Circle

POLYLINE Connected Lines
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IGES
GibbsCAM can export geometry and solids
as IGES surface entities. When exporting to
the IGES format file format (once the file has
been named and saved), the dialog shown to
the right will come up. The information can be
altered as needed by the user. This dialog
contains header information that will be
written to the IGES file. The file namewill be
entered as it was in the Export dialog and the
information will default to previous entries
made in those fields. The Generation Date &
Time is set according to the date and time on
the computer.

Once the header information has been entered, the Export
Filter dialog shown to the right will come up. This dialog
controls how the file will be created. The Features group
allows the user to select which features to export. Points,
lines, circles and curves can be exported. The Units group
allows parts to be exported in inches or metric units. The
Suppress Z checkbox is available only when exporting
DXF files.

IGES is supported bymanyCAD systems and is published by the National Bureau of Standards,
US Department of Commerce. The IGES entities shown in the following table can be exported by
GibbsCAM.

Entity # Entity Name Feature Equivalent

100 Circular Arc Entity Circle

110 Line Entity Line

116 Point Entity Point

124 TransformationMatrix Entity Coordinate System Information

126 Rational B-Spline Curve Entity Connected lines

Point List
When exporting a point list, only the name and location to save the file need to be specified. To
create the point list text file, click on the Save button. The resulting text file will contain the X, Y, and Z
coordinates of any points contained in the current file. Each point will be on a separate line and each
coordinate value will be separated by one space.
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Solid Export
GibbsCAM canwrite files into different file formats including Parasolid, ACIS, and STL. In many
cases files can be exported to various versions of many types of formats. Each export will display its
version in the Save as type list as shown. To save the file to the latest version use the entry with no
version number listed.

ACIS

.sat Files

GibbsCAM supportsmultiple versions of ACIS (.SAT) files starting with v6. You can save amodel
to older ACIS versions to be compatible with older CAD systems. To save the file to themost recent
version of SAT, use the ACIS-SAT (*.sat) entry with no version number listed.

Parasolid

.x_t Files

Both sheets and solids can be exported into Parasolid files. Parasolid can be exported tomany
versions. GibbsCAM is based on the current Parasolid technology.When the standard Parasolid
(*.x_t) item is selected for the file type, the resulting file will be based on the current version of
Parasolid. Older versions display their version numbers. These selections can be used to export a
Parasolid file that will be compatible with a system using older Parasolid technology.

If you export a facet body to Parasolid, two files will be created: filename.x_t and filename.x_
t_fbi.

Stereolithography

.stl Files

An STL file is for use with stereolithography systems. An STL file is a facetedmodel, not a surface
model. The file contains no surface information, only the faceting information necessary to
represent or render themodel.

ASCII / Binary. ASCII files are nearly four times larger than binary files, but aremore portable and
more human-readable.

Regular / Plus. When you export to STL [ASCII] or STL Binary, the faceting tolerance is determined
by the chord height set for the body in its Properties dialog.When you export to STL Plus [ASCII] or
STL Plus Binary, you specify facet accuracy as you export.



Export

31

Neutral-Format (ATB) for PTC Creo Parametric
(Creo Elements, Pro/E Wildfire)

.neu Files

Note: PTC Creo Parametric was formerly known asCreo Elements and as Pro/ENGINEER
(informally: “Pro/E”).

The PTC Creo Parametric (GRANITE) option adds the ability to export solids to Neutral format,
also called ATB (for Associative Topology Bus).

STEP - AP203, AP214, and AP242

.step and .stp Files

The STEP (GRANITE) option adds the ability to export solids to the STEP (AP203, AP214 and
AP242) formats.
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Transfer Add-Ins

CAD Interoperability
GibbsCAMprovides for several CAD Transfer Add-Ins. These Add-Ins provide interoperability
between: GibbsCAMand Autodesk Inventor, GibbsCAMand KeyCreator, GibbsCAMand
Rhinoceros, GibbsCAMand Solid Edge, GibbsCAMandCimatronE, andGibbsCAMand
SOLIDWORKS. TheGibbsCAMTransfer Add-In creates amenu item in your CAD application that
allows for a part to be directly transferred to GibbsCAM. The Add-Inmaintains associativity
between the nativemodel and toolpath generated in GibbsCAM. Associativity will remain as long as
themodel has not been changed within GibbsCAM.

Common Functionality
When a part is transferred, a new file will be created with the same name as the original part.
GibbsCAMwill automatically launch if it is not currently running. If GibbsCAM is running and has an
open part file you will be prompted with the optionsNew Part, Insert and Replace.

New Part
New Partwill close the current GibbsCAM file and create a new part file with the new part.

Insert
Insertwill add the new part to the current GibbsCAM file.

Replace
Replacewill replace all bodies that are designated as a “Part” in the Properties dialog with the new
part. Bodies that are designated as “Stock” or “Fixture” are not replaced.

Note: In some rare instances, GibbsCAMmay display an error upon launching and the part will not
be transferred. If this happens, clickOK on the alert, and retry the transfer. Also, some types of
geometry editsmay invalidate the associativity, (e.g. topological changes).

Autodesk Inventor Transfer Add-In
TheGibbsCAMAutodesk Inventor Transfer Add-In lets you transfer Autodesk Inventor file types for
parts (*.ipt) and assemblies (*.iam). Only one file type can be transferred at a time.When
transferring, all sub-assemblies are dissolved into themain assembly. After bodies are transferred
to GibbsCAM, they are separate solids that can be handled individually.

The CAD Transfer Add-In for Autodesk Inventor must be installed on the systemwhere Autodesk
Inventor is installed.

Use
The Add-In is accessed from Inventor'smainmenu: Add-Ins > Transfer To GibbsCAM.

You can store Autodesk Inventor features in a way that makes them understandable to GibbsCAM.
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What Are Autodesk Inventor Features?

Autodesk Inventor defines several kinds of features: holes, extrusions, fillets, chamfers, and so
forth. Features in Autodesk Inventor part files (*.ipt) and assembly files (*.iam) can be
understood byGibbsCAM14, but only if theywere saved while the GibbsCAMCAD Transfer Add-
In for Autodesk Inventor was installed on the Autodeskworkstation.

Such feature data can sometimes be quite large, and it is not always needed. In GibbsCAM, you
can optionally set a switch that suppresses the importation of such feature data, using the Inventor
Options dialog box:

To open this dialog box: Plug-Ins > (Misc) > Autodesk Inventor Options

Importing Autodesk Inventor Features

To import features stored in an *.ipt or *.iam file that was saved in Inventor while the GibbsCAM
CAD Transfer Add-In for Autodesk Inventor was installed, follow these steps.

Before you begin: On your GibbsCAMworkstation, youmust have installed either Autodesk
Inventor or Autodesk Inventor View, 2014 or later. (Note that Autodesk Inventor View is available
as a free download.)

1. File > Import; navigate to the Autodesk Inventor file and open it. The following sample file is
supplied: Pockets_with_Features.ipt

2. In the Solid File Import Options dialog, specify the settings you prefer.
3. In the information dialog, specify preferences for stitching and units and then click OK.

Result: The Define CAD Attribute Map dialog appears. (Note: This can take several minutes
if the file containsmany hundreds of features.) If the dialog does not appear, use Plug-Ins
menu option Autodesk Inventor Options as noted above to specify importation of features.

4. In this dialog, specify the types of Inventor features to import, and then click OK.
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5. To view andmanipulate feature data within GibbsCAM, use Features > Feature Manager.

KeyCreator Transfer Add-In
TheGibbsCAMKeyCreator (v6.3 and above) Transfer Add-In will transfer design (CKD)
KeyCreator file types. Only one file typemay be transferred at a time. This add-in process needs to
be repeated with each launch of KeyCreator.

Use
To transfer a KeyCreator part choose Add-Ins > CDE open. Then browse to the GibbsCAM
installation folder and open the KeyCreator folder, select KeyCreator Addin.CDE andOpen. Now click
the Transfer button. Themodel will rotate to a top view and transfer. The transfer can also be
accessed from Add-Ins > GibbsCAM > Transfer > GibbsCAM Transfer located your KeyCreator menu
bar.
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Rhinoceros Transfer Add-In
TheGibbsCAMRhinoceros Transfer Add-Ins will transfer design (3DM) Rhinoceros 3.0, 4.0 and
5.0 file types. Only one file typemay be transferred at a time. This add-in process needs to be
repeated with each launch of Rhino.

Use
To transfer a Rhinoceros part choose Tools > Options. Then select Plug-ins from theOptions list and
click the Install button. Browse to the C:\Program Files\Common Files\GibbsCAM Shared\Interchange\
folder, open the Rhino5 folder and select GibbsCAM.RHP. Click the selectionOpen > GibbsCAM
>Transfer Part To GibbsCAM that is now available in your Rhinomenu bar.

Solid Edge Transfer Add-In
TheGibbsCAMSolid Edge Transfer Add-In allows you to transfer part (PAR), draft (DFT),
assembly (ASM), and sheet metal (PSM) Solid Edge file types. Only one file typemay be
transferred at a time.

Use
Within the Solid Edge application, usemenu option Add-Ins > Transfer Part To GibbsCAM.

SolidWorks Transfer Add-In
TheGibbsCAMSolidWorks Transfer Add-In will transfer SolidWorks file types for parts
(*.SLDPRT), assemblies (*.SLDASM), and drawings (*.SLDDRW). Only one file type can be
transferred at a time.When transferring, all sub-assemblies are dissolved into themain assembly.
After bodies are transferred to GibbsCAM, they are separate solids that can be handled
individually.

The CAD Transfer Add-In for SolidWorksmust be installed on the systemwhere SolidWorks 2011
or later is installed. SolidWorks 2011 (or later) is required for the Add-In to work.

Use
The SolidWorks Transfer Add-In is accessed from GibbsCAM Transfer Add-In >Transfer Part To
GibbsCAM.

Installing the Add-In on Workstations Without GibbsCAM
If you need to install the SolidWorks Add-In on a workstation that does not run GibbsCAM, run the
standalone installer (*.msi file) provided on theGibbsCAM installation DVD (under
Content\Tools\).

If you have aGibbsOnline Services account, you can download a 32-bit or 64-bit version of this
standalone installer from https://online.gibbscam.com : Software Downloads > Tools. TheMSI file
can be freely distributed; however, be careful to review the license agreement.
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CimatronE Transfer Add-In
TheGibbsCAMCimatron Add-In allows direct transfer of CimatronE files into GibbsCAM. You can
either transfer the entire screen display or selected entities.

Installation
When installing a newer version of GibbsCAM it is important to select the newest version of
CimatronE.

If you are running an older version of GibbsCAMwith CimatronE already installed, you need to first
uninstall CimatronE (Change installation) before installing the latest version in order for GibbsCAM
to take advantage of the new CimatronE Add-ins.

Use
The Add-In is accessed from GibbsCAM > Transfer/GibbsCAM Transfer Selected.



Conventions

37

Conventions
GibbsCAMdocumentation uses two special fonts to represent screen text and keystrokes or
mouse actions. Other conventions in text and graphics are used to allow quick skimming, to
suppress irrelevancy, or to indicate links.

Text

Screen text.  Text with this appearance indicates text that appears in GibbsCAMor on your monitor.
Typically this is a button or text for a dialog.

Keystroke/Mouse.  Text with this appearance indicates a keystroke or mouse action, such as
Ctrl+C or right-click.

Code.  Text with this appearance indicates computer code, such as lines in amacro or a block of
G-code.

Graphics

Some graphics are altered so as to de-emphasize irrelevant information. A “torn” edge signifies an
intentional omission. Portions of a graphicmight be blurred or dimmed to highlight the item being
discussed. For example:

Annotations on a graphic are usually numbered callouts (as seen above), and sometimes include
green circles, arrows, or tie-lines to focus attention on a particular portion of the graphic.

Faint green borders that outline areaswithin a graphic usually signify an imagemap. In online help
or a PDF viewer, you can click a green-bordered area to follow the link.
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Links to Online Resources

Link URL Action / Description

Go http://www.GibbsCAM.com Opens themain website for GibbsCAM.

Go https://online.gibbscam.com

Opens a restricted website containingmaterials
available for download. Requires aGibbsCAM
Online Services account; to set up an account,
contact GibbsCAM Support.

Go https://store.GibbsCAM.com
Opens the website for the GibbsCAM Student
Store.

Go https://macros.gibbscam.com
Opens a wiki containing documentation and
examples of GibbsCAMmacros. Requires a
GibbsCAM account.

Go http://kb01.GibbsCAM.com

Opens a Knowledge Base article, Contour
Operations Using Thread Mill Tools, that
explains in detail the correct way to program
Contour processes using ThreadMill tools.

Go mailto:Support@gibbscam.com
Runs your email client to create a new message
addressed to the CAMBRIO Technical Support
department for GibbsCAM.

Go mailto:Registration@gibbscam.com
Runs your email client to create a new message
addressed to the CAMBRIORegistration
department for GibbsCAM.

Go mailto:Sales@gibbscam.com
Runs your email client to create a new message
addressed to the CAMBRIO Sales department
for GibbsCAM.

Go http://www.autodesk.com/inventor
Opens an external website that provides more
information on Autodesk Inventor products.

Go http://www.celeritive.com
Opens an external website that provides more
information on VoluMill Ultra High-Performance
Toolpath (UHPT) from Celeritive Technologies.

Go http://www.predator-software.com
Opens an external website that provides more
information on a CNC editor and a virtual CNC
viewer from Predator Software, Inc.

http://www.gibbscam.com/
https://online.gibbscam.com/
http://store.gibbscam.com/
https://macros.gibbscam.com/
http://kb01.gibbscam.com/
mailto:Support@gibbscam.com
mailto:Registration@gibbscam.com
mailto:Sales@gibbscam.com
http://www.autodesk.com/inventor
http://www.celeritive.com/
http://www.predator-software.com/
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